I cant' use Netbenas to develop ruby

I try to develop ruby with netbeans and mysql.I try to generate
controller XXX and views YYY and I try access my tested web.But it shows
me
                We're sorry, but something went wrong.
We've been notified about this issue and we'll take a look at it shortly

                  What's wrong. I used WEbrick as server

                                                      Thanks

Try to set config.action_controller.consider_all_requests_local = true for your development environment
It will show proper Exeption message instead of "We're sorry, but something went wrong."

Have a look in log/development.log for more information (assuming you
are running in development mode). Possibly you have not setup the
database connection in config/database.yml.

Colin

Try to set config.action_controller.consider_all_requests_local = true
for your development environment
It will show proper Exeption message instead of "We're sorry, but
something went wrong

I stay on the command line for the generators and such, using Netbeans
to do the other programming tasks.

This problem should have nothing to do with Netbeans. I have been
using Netbeans for a long time and still get that error sometimes.
It's always my fault, not Netbeans's. :wink:

It might be that your DB configuration is not setup correctly or that
you have a typo in your URL, or...

I would check first the 'database.yml' file contents and go from
there.

Tanawat Limungkura wrote:

I try to develop ruby with netbeans and mysql.I try to generate
controller XXX and views YYY and I try access my tested web.But it shows
me
                We're sorry, but something went wrong.
We've been notified about this issue and we'll take a look at it shortly

                  What's wrong. I used WEbrick as server

                                                      Thanks

I had this problem what I found is that the Webrick server port snd the
localhost prot were pointing in different places. The Webrick sever
should be by default http://localhost:3000 and for Apache
http://locahost:8080. however this can change if Netbeans detects the
port is being used. Couple options <Window> choose Server. see if
Webrick is present. If it is remove an reinstall. Or go into you project
properties and make sure the Server you are running on and the port
number in your URL match.

I think you have to install mysql2 gem. then this should be work.