Dev Environment

Hi All,

I am new Ruby on Rails, I had installed as described below on my machine. Could you please advise good editor compatible to the below configuration? And any additional steps required once i install these?

  1. MySQL 5.6.27
  2. Ruby 2.2
  3. Git
  4. Rails 4.0 Appreciate your help! Thank you.

You have not told us which operating system you are using. Assuming it is a linux or Mac OS then I recommend installing using rvm (others prefer rbenv).

However I suggest that you start by working right through a good tutorial such as railstutorial.org (which is free to use online). This tutorial runs in the cloud and does not need you to install anything to get going. Once you have learnt the basics then installing on your own machine will be easier as you will know what to expect.

As a matter of interest why have you installed an almost obsolete version of Rails? 4.2.4 is the current version.

Colin

Hi All,

I am new Ruby on Rails, I had installed as described below on my machine. Could you please advise good editor compatible to the below configuration?

There are several good coding editors to choose from:

* Sublime Text 2 or 3 * Atom * Brackets

Most people don't recommend RubyMine as it can be costly, and many people do not think using an IDE helps one learn enough, however I find it useful enough even if it isn't my main editor, which is emacs.

I have a hard time recommending Vim and Emacs to new developers, even though they are both really great editors. The problem being, perhaps, as editors they both can have their own learning curve piled on top of learning the framework.