Zlib error

Hi,

After installing the rubygems 1.3.1, I face the following issues while
installing new gems.

Error:

arun@mysystem:~/Desktop$ sudo gem install ip2country-0.0.2.gem

ERROR: While executing gem ... (Zlib::GzipFile::Error)
    not in gzip format

My Environment:

OS - ubuntu 8.04 - the Hardy Heron version.

Ruby - ruby 1.8.6 (2007-09-24 patchlevel 111) [i486-linux]

RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.1
  - RUBY VERSION: 1.8.6 (2007-09-24 patchlevel 111) [i486-linux]
  - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: /usr/bin/ruby1.8
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /usr/lib/ruby/gems/1.8
     - /home/arun/.gem/ruby/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/

Please suggest a solution. I want to install required gems. Do i need to
revert my rubygems version? because in my older version rubygems-1.0.1,
i dont see any errors. is it a bug in rubygems-1.3.1 or do i need to
change anything?

Thanks,

Arun.