Error in Gem update or install

Hi,

  I am newbie to rails, i install ruby and dependences like ruby-dev
libopenssl-ruby1.8 irb ri rdoc but i try install rubygems is perfect ,
but i update or install any gem means , it show the below error.

$ gem update --system
ERROR: While executing gem ... (Zlib::GzipFile::Error) not in gzip
format

i google search it, it says check like

$gem -v => 1.8.10

$gem sources => *** CURRENT SOURCES *** http://rubygems.org/

$gem env =>

RubyGems Environment:
  - RUBYGEMS VERSION: 1.8.10
  - RUBY VERSION: 1.8.7 (2010-06-23 patchlevel 299) [i686-linux]
  - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: /usr/bin/ruby1.8
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /usr/lib/ruby/gems/1.8
     - /home/encore/.gem/ruby/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

$whereis gem => gem: /usr/bin/gem1.8 /usr/local/bin/gem

sorry cant indentify it what error ,pls if you what error suggest me...

thanks in advance

sathish k. wrote in post #1021926:

Hi,

  I am newbie to rails, i install ruby and dependences like ruby-dev
libopenssl-ruby1.8 irb ri rdoc but i try install rubygems is perfect ,
but i update or install any gem means , it show the below error.

$ gem update --system
ERROR: While executing gem ... (Zlib::GzipFile::Error) not in gzip
format

sorry cant indentify it what error ,pls if you what error suggest me...

thanks in advance

Have you installed the Zlib library. Seems the Zlib library is missing.

# apt-get install zlib1g-dev (ubuntu or debian)

This might help you.

TML