Zlib problem

Dear all!

I had a Zlib problem so tried to solve with RVM:

$ rvm package install zlib
$ rvm remove 1.9.2
$ rvm install 1.9.2 --with-zlib-dir=$rvm_path/usr

Did not help. Sill receive this message for ‘rails server’:

$ rails server

/…/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in **require': /lib/libz.so.1: version ZLIB_1.2.3.3’ not found** (required by …/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/i686-linux/zlib.so) - /.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1**/i686-linux/zlib.so (LoadError)**

Tried to install Zlib from source. I could make “./configure” and “make” but “make install” gave this output:

“makeinstall: command not found”

Every forum says I should install build-essential package. It was already installed, I reinstalled, didn’t helped.

What I make wrong? Any help is highly appriciated, I have no idea but it’s important. Many thanks, best wishes,

Zoli

Hi Zoli - did you ever solve this? got the exact same problem and have
followed the exacts same path as you so far.

max

i can not trash zlib.so can you help me