The Upcoming 2.3.11 Release

Hey Guys,

We've had a rough few point releases in the 2.3 series. As a result I
know there are people who are sitting on earlier releases rather than
running 2.3.10. This is obviously not ideal. Especially for a
release series that's in long-term maintenance mode.

So to fix all that I'd like to put a bunch of effort into tidying up
the 2-3-stable branch to remove most / all of the upgrade blockers
that people have hit. This will let people upgrade to 2.3.11 and pick
up the bugfixes and security fixes which have been applied to that
release. It'll also set us up nicely for any future bugs that get
fixed.

So, if you have a 2.3.x application which can't be upgraded to 2.3.10
( or 2-3-stable as of today ) please reply to this thread and include
a link to a lighthouse ticket so we can take a look.

Thank you, this is excellent news. You already applied the patch that
fixes the issue we had with 2.3.10, but we'll check out the latest
2.3-stable.

https://rails.lighthouseapp.com/projects/8994/tickets/5568-239-destroy_all-destroys-loaded-records-that-do-not-match-the-scope-on-associations

Thanks!

This is on my TODO list for the next few days, will report back shortly.

- Ken

This one is broken between 2.3.6 and 2.3.10…

https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/5873-fix-broken-rack-params-parser-in-rails-236#ticket-5873-5