Can someone take a look at this pull request?
I’m working on a different PR and there are a few places in the Rails source that needs to determine if a String is countable or not (example). I would submit a PR for String#countable? and String#uncountable? and refactor these checks, but because of the similarity in nature, I’d like to wait until #6802 is merged before I begin.
After the refactoring, the line I linked would become:
if name.countable? && name.plural? && !options[:force_plural]
…which IMO is much more readable and the intent is much more explicit.