RedCloth gem/pluging not working in production mode


I installed RedCloth 4.1.1 using - gem install RedCloth - This has worked fine on my development (webbrick) machine.

I then did the same on my production machine which is using Apache and Passenger. However the plugin/gem appears not to be found. Do gems and plugins need to be handled differently in production mode or with Apache and Passenger? This is the first time that I am using a plugin.

Assistance would be most appreciated.

Paul Thompson

I had a similar problem a while back and had to add the following to my environment.rb file:

config.gem "RedCloth", :version => ">= 4.1.1", :source => "http://"

This should go in the block.


Hi Sheldon,

Tried what you advised. Am getting this message on starting Webrick (I thought I would test it here before trying in production)

=> Booting WEBrick... /usr/local/lib/site_ruby/1.8/rubygems/requirement.rb:150:in `parse': Illformed requirement [{:source=>"", :version=>">= 4.1.1"}] (ArgumentError)   from /usr/local/lib/site_ruby/1.8/rubygems/requirement.rb:75:in `initialize'


Paul Thompson

Always good to test it in development before moving it to production. :slight_smile: Never seen that error myself. Let me copy and past what I have from the environment.rb file. I was typing that earlier post from memory:

config.gem "RedCloth", :version => ">= 4.1.1", :source => "http://"

This is on an app which is running rails 2.1, although it should work fine on 2.2+. It's added just before the closing end on the block in config/environment.rb.

Sheldon F.

I'm having a similar problem. My Apache log shows the following error. Passenger doesn't load completely so the rails log isn't written to.

RedCloth 4.1.1 is also installed on the both the production and development environments and shows up in the 'gem list' call.

I don't have problems in development (OS X, Apache, passenger) but production is messed. I'm on Ubuntu running Apache and Passenger. I have Rails 2.2 on both development and production environments.

#Passenger error on restart Ruby on Rails application could not be started The application has exited during startup (i.e. during the evaluation of config/environment.rb). The error message may have been written to the web server's log file. Please check the web server's log file (i.e. not the (Rails) application's log file) to find out why the application exited.

# Apache error log You're running:   ruby at /opt/ruby-enterprise-1.8.6-20081215/bin/ruby   rubygems 1.3.1 at /home/etandrib/.gem/ruby/1.8, /opt/ruby- enterprise-1.8.6-20081215/lib/ruby/gems/1.8

Run `rake gems:install` to install the missing gems.

# environment.rb do |config|   config.gem "RedCloth", :version => ">= 4.1.1", :source => "http://" end