config.gem hassles (again)

Just when i think i've got my head around including gems with gem.config in my environment.rb file i hit another hurdle. The latest one involves redlcoth, which one of my plugins needs.

my installed redcloth gem is in this folder:

  /var/lib/gems/1.8/gems/RedCloth-4.2.2/

and its main lib folder is called 'redcloth'.

I managed to freeze it into my app by calling config.gem as follows:

  config.gem "RedCloth", :version => '4.2.2', :lib => "redcloth"

Initially i had the first argument as "redcloth" but this didn't work - presumably it needs the name of the gem folder (minus version number) and is case sensitive?

Anyway, because i'd managed to freeze it into my vendor/gems folder, i thought everything was cool. But when i try and run a rake task i get this error:

  The following gems have native components that need to be built     RedCloth = 4.2.2

  You're running:     ruby 1.8.6.111 at /usr/bin/ruby1.8     rubygems 1.3.5 at , /home/max/work/akrotoski_container/akrotoski/thoth, /home/max/.gem/ruby/1.8, /var/lib/gems/1.8

  Run `rake gems:build` to build the unbuilt gems.

If i run rake gems:build, i get the same error back, which is the usual frustrating problem i've had in the past with this stuff.

Can anyone see what i'm doing wrong? thanks, max