Problems installing Ruby and Rails on Mac OSX 1.3.9 (Panther)

Yes, before you ask, I'm new to this and feel pretty useless.

I have followed the hivelogic article to the letter, and must be one of
the few who still failed installation.

A couple of questions that might set me on the right path:
1) Does the hivelogic guide work for PPC/Panther, or is it only for
Tiger?
2) I think I have a problem with permissions on my mac. Despite logging
with an Admin account, there are certain things it won't let me do,
saying I don't have permissions (e.g. permission denied when using mv
command, and would not let me write a .bash_profile file)
3) I understand that the .bash_login file should be created in the home
directory...is that the directory that starts with ~ ?

The weird thing is that the install seemed to work until I tried the
rails command - didn't recognise it. Then i checked ruby -v and it
still showed the old pre-installed version (1.6) so I'm really not sure
what has been successfully installed

By the way, is there any way to see hidden/system files with Finder?

Thanks for your help.

forgot to mention: I tried rails -v and got tcsh: rails: Command not
found...so clearly install failed.

Hi,

Before we start, I will plug my own application
(http://locomotive.raaum.org). But if you want to get it set up on
your own, here's some thoughts.

Problem 1. Your shell is not bash, it's tcsh. That means that all
those bash settings the hivelogic article is telling you to do will
have no effect.

Solution 1. Probably the easiest thing to do is change your shell to
bash.
http://www.askdavetaylor.com/how_do_i_change_my_default_shell_in_mac_os_x_panther_from_tcsh_to_bash.html
(I would use the Netinfo Manager method)

Problem 2. Permissions problems. You should always have write
permission in your own home folder, but generally you will have to
'sudo' changes in the /usr/local hierarchy.

...

Change your shell, make sure the new bash shell is set up properly and
then see if rails is ok. If not, you may have to redo the
installation.

Best,

-r

Sweet, thanks ryan.

Changed the shell to bash and, just like that, it recognised the new
ruby installation!

Next I tried to reinstall gems and rails but that still is not working
:frowning: strange, because I can see the gem and ruby executables in
/usr/local/bin/

when i try to install rails, i get the
/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:10:in
'require':no such file to load --digest/sha2 (LoadError)

Huh?

I suspect rubygems is not installed properly in the /usr/local ruby
(given the shell/path issues you had in the first round). I would
suggest removing the ruby lib directory ( "sudo rm -rf
/usr/local/lib/ruby" ) and starting over after the readline install
point in the hivelogic tutorial.

-r

Thanks ryan - I'll give it a try next week, away from my mac right now.
I'm sure it will work this time.