Suddenly Nothing is working

Hello all.

I've been developing with RoR for several months and have enjoyed
every second. When I began I ran through the Hivelogic install process
and got everything working. Got it woking with Apache as well.

Recently (I believe this happened after I updated Rails) everything
stopped working. I can browse my sites using WEBbrick but not under
Apache. I get this error:

Application error

Change this error message for exceptions thrown outside of an action
(like in Dispatcher setups or broken Ruby code) in public/500.html

When I check my logs I find this oddity:

Permission denied -
/Users/elcento/Sites/hottonic/public/../config/../tmp/sessions//ruby_sess.d80cdc38dc7fbcfe

Any idea what could be happening? I'm a bit stumped. I've reinstalled
everything to no avail.

Versions:
OSX (Tiger)
Apache
MySQL Client Version 5.0.10
Rails 1.1.6
Ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]

Thanks in advance.
Don C.

You have a permsissions error

Make sure your tmp directory is write all .. or at least by the apache
process user/group

Hi Don,

sounds like a file permission problem. IMHO you’re underlying operating system isn’t granting you the appropriate permissons on the said session file in the tmp folder. Have you access to these files by ssh, ftp or the like? You might try to delete the temporary session file or chown it to the necessary user (by using chown -R apache:apache [your folder] for example)

Cheers,
Jan

Thanks a lot. That worked.

Any idea why Rails generates these directories without the permissions
set to write-all? Security I presume.