Plugin or Gem install is too slow

What version of RubyGems?
Are you getting your pugins with Git or Subversion?
Have you tried to ssh into another box on your network? Is that slow
also?
Are you on a wired or wireless connection?
Are you on a company LAN?
Have you tried installing gems or plugins from a different location
(maybe a Wi-Fi hotspot)?
I have seen odd connection issues in the past on networks with improper
DNS configurations.

Soh Dubom wrote:

My RubyGems is 1.2.0

I didn't install the plugins via Git or SVN, just used the terminal, ex:

script/plugin install
http://svn.viney.net.nz/things/rails/plugins/acts_as_taggable_on_steroids/

And then wait for around 30min to have it finished.

I'm at home with a wireless connection.

I'll first try the non-wireless mode, then try another box, maybe
Windows, just to see what happens.

You might what to install it with the verbose flag ( -v ) to see why
its taking so long. Also , with atleast gem <1.2 , passing the flags --
no-rdoc --no-ri to the gem install command would speed it up , you get
no documentation though.

Also you might want to ping the server itself to see if its just the
server.

James