Not able to run gem install sqlite3-ruby (help needed)

when i run gem install sqlite3-ruby i get the following error

C:\>gem install sqlite3-ruby
Select which gem to install for your platform (i386-mswin32)
1. sqlite3-ruby 1.2.1 (mswin32)
2. sqlite3-ruby 1.2.1 (ruby)
3. sqlite3-ruby 1.2.0 (mswin32)
4. sqlite3-ruby 1.2.0 (ruby)
5. Skip this gem
6. Cancel installation

2

Building native extensions. This could take a while...
ERROR: While executing gem ... (Gem::Installer::ExtensionBuildError)
    ERROR: Failed to build gem native extension.

ruby extconf.rb install sqlite3-ruby
checking for sqlite3.h... no

nmake
'nmake' is not recognized as an internal or external command,
operable program or batch file.

Gem files will remain installed in c:/ruby/lib/ruby/gems/1.8/gems/
sqlite3-ruby-1
.2.1 for inspection.
Results logged to c:/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.1/
ext/sqlite3_
api/gem_make.out

Can anybody give me a solution

Thanks in Advance
Vijay Kumar

Choose number 1 if you're on windows (mswin32)

Note that if you update your rubygems it does this automatically now
gem update --system

Vijay wrote: