no such file to load -- thread (LoadError)

Hi All,

I removed all my rails and then ruby installation using sudo apt-get
remove and by deleting all gem and ruby folder manually.

Then I installed ruby. And tried to install gem(1.3.5 and1.3.6 also)
using
ruby setup.rb

I got following error

./lib/rubygems.rb:9:in `require': no such file to load -- thread
(LoadError)
  from ./lib/rubygems.rb:9
  from setup.rb:24:in `require'
  from setup.rb:24

I am trying to resolve it but I not found any thing

Regards,
Rahul P. Chaudhari