Newbie: Bundle EACCESS

Hi everybody,

I'm actually following the rail for zombies tutorial and I have been
trying to get RoR installed on my computer for a few days. I followed
all the tutorials I found, tried all the different sources and methods
and it still doesn't work. If somebody can help me, I will make a statue
of him and create a new cult for him...

Anyway, here is the bug I know encounter (I could just go from one bug
to another):

I used the one click rails installer. Everything's OK, at the end, it
asks me my name and adress. I had already a problem here, now more or
less fixed. Then, when I am creating a new project (using git or the
command prompt are the same), at the line "run bundle install" I get the
following statement:
Fetching source index for https://rubygems.org/
Could not reach rubygems repository https://rubygems.org/
Could not find gem 'jquery-rails (>=0) x86-mingw32' in any of the gem
sources listed in your Gemfile.

I also tried to update gem:
gem update --system
ERROR: While executing gem...(Gem::RemoteFetcher::FetchError)
  Errno::EACCESS: Permission denied - connect(2)
(http://rubygems.org/latest_specs.4.8.gz)

As I am connected behind the proxy of my school I tried to configurate
it (SET HTTP_PROXY=myProxy) but nothing changed. However, I don't know
much about this technology and I am not sure the parameters I got
are the good ones (I used netstat, tried with and without the domain...)
It worked in my neighbour's room, but we are not using the same OS
system so...

I have been using Windows 8 for some weeks, is there any known
compatibility problem?

Thank you for everything,

D

Hi everybody,

I’m actually following the rail for zombies tutorial and I have been

trying to get RoR installed on my computer for a few days. I followed

all the tutorials I found, tried all the different sources and methods

and it still doesn’t work. If somebody can help me, I will make a statue

of him and create a new cult for him…

Anyway, here is the bug I know encounter (I could just go from one bug

to another):

I used the one click rails installer. Everything’s OK, at the end, it

asks me my name and adress. I had already a problem here, now more or

less fixed. Then, when I am creating a new project (using git or the

command prompt are the same), at the line “run bundle install” I get the

following statement:

Fetching source index for https://rubygems.org/

Could not reach rubygems repository https://rubygems.org/

Could not find gem ‘jquery-rails (>=0) x86-mingw32’ in any of the gem

sources listed in your Gemfile.

I also tried to update gem:

gem update --system

ERROR: While executing gem…(Gem::RemoteFetcher::FetchError)

Errno::EACCESS: Permission denied - connect(2)

(http://rubygems.org/latest_specs.4.8.gz)

As I am connected behind the proxy of my school I tried to configurate

it (SET HTTP_PROXY=myProxy) but nothing changed. However, I don’t know

much about this technology and I am not sure the parameters I got

are the good ones (I used netstat, tried with and without the domain…)

It worked in my neighbour’s room, but we are not using the same OS

system so…

Sounds like you’re missing some of the proxy configuration. See this SO post for more ideas:

http://stackoverflow.com/questions/4418/how-do-i-update-ruby-gems-from-behind-a-proxy-isa-ntlm

Especially note the comment about escaping backslash () characters; no idea if it’s relevant to your particular situation, but it’s the kind of easy-to-overlook detail that can break stuff.

–Matt Jones

Hey Matt,

Thank you for answering. Actually, Isolved my problem, which came from
an accent in my name. The tricky thing was that only a part of the
programm had a problem with it. So everything installed correctly but
bundler refused to work.

Anyway, thx.

D