(Gem::RemoteFetcher::FetchError) can't get connected to the net!

Hello everyone, I recently picked up the Agile web dev with Rail book
and followed the installation instructions for Windows using
InstantRails... well it works up until the point i try to......

'gem update rails --include-dependencies'

..... i end up with the following error message:

pdating installed gems...
ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
    A Request to send ro recieve data was disallowed because the
socket is not connected and (when sending a datagam socket using a
sendto call) no address was supplied. (Errno::ENOTCONN) getting size
of http://gem.rubyforge.org/Marsha1.4.8

hmmm don't really know what all that means.. there isn't a firewall
blocking it.. so i tried the RubyonRails.org method of installation
and i was able to progress as far as installing gems.......

'gem install rails --include-dependencies -v'

........i get this error message:

ERROR: http://gems.rubyforge.org/ does not appear to be a repository
ERROR: could not find gem rails locally or in a repository.

now i can ping gems.rubyforge.org.. i see the firewall allowing ruby
to go out to this address yet gem doesn't seem to have any luck gettin
out to the net.

4 hours of searching thought manuals, docs, forums, tutorials and
various blogs on http proxy, im still at a loss. The firewall was
turned off completely and still no change, i just uninstalled hamachi
just incase.. no change.. I'm behind a netgear router im not sure if
that is a factor or not.

Any help or insight to this situation would be greatly appreciated,
thanks!

My OS: Windows XP pro, SP1.

Some thoughts:
Make sure you have the latest version of gems [1.2]

If worst comes to worst I suppose you could download the gems by hand to
your local machine then run gem install on them :slight_smile:

As a note, at least on my machine [OS X] that command works.
-=R

[1]
http://www.akitaonrails.com/2008/7/26/still-playing-with-ruby-on-windows