Newbee Question

I have been trying to start working on some projects on RoR since last
week.

Read some books(its surpricing how many books there are on the matter)
and tried some of the examples to mostly NO success.

What is the version of rails I should be working with. I have a
Macbook Pro Leopard. I have installed 2.1 of rails and cant follow
many of the now aged tutorials because of conventions changing on
rails 2.0.

This is frustrating as I want to start being agile.

What version of RAILS is most recommended for a newbee like me?

Thanks Guys,

Hi,

There's plenty of tutorials and examples based on 2.0
That is the one I'm using (and the one that my hosting service supports
so far).

I really enjoyed this one:
http://www.akitaonrails.com/2007/12/12/rolling-with-rails-2-0-the-first-full-tutorial

I also enjoy the railscasts: http://railscasts.com/

...I have to update to 2.1 at some point.

Hope it helps.