Instant Client: Connecting Oracle and Mac

Hi,

I am having a terrible time installing Instant Client to connect my
Mac and an Oracle db.

I am using the following instructions:
http://www.foliosus.com/2007/11/19/connecting-ruby-on-rails-to-oracle-on-an-intel-mac-in-leopard-mac-osx-105/?css=Banksia

All goes seemingly well until the Compile the ruby-oci8 library
section.

ruby setup.rb config

returns the following error message:

Downloads/ruby-oci8-1.0.3/ext/oci8/extconf.rb:24
'system /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/
ruby /Users/lynnlobash/Downloads/ruby-oci8-1.0.3/ext/oci8/extconf.rb '
failed
Try 'ruby setup.rb --help' for detailed usage.

Anyone have any experience with this?

Thank you,
Lynn Lobash