Is there any RAILS DUDE to HELP me out kick this problem?

im new one to rails practising rails with sqlite but now it a situation for me to use oracle with rails i have tried to configure oracle with rails but is show me the following error

activerecord oracle_enhanced adapter could not load ruby-oci8 load error

but i have installed needed gems for configuring oracle

gem ‘activerecord-oracle_enhanced-adapter’, ‘~> 1.4.0’

gem ‘ruby-oci8’, ‘~> 2.1.0’

and also i have downloaded oracle instant client but still it does’nt work

ill be happy if any body give me the step by step explanation on how to configure oracle?

How did you configure ruby-oci8 in your rails project?

i’ve done gem install rubi-oci8[this is one way which i’ve tried]

when i do this in command prompt it shows ruby-oci8 gem installed…

another method in command prompt i’ve tried ruby **ruby ruby-oci8-2.1.3-x86-mingw32.gem **

but it doesnt work

could u kindly assist me by giving proper guidance to configure oracle in rails

currently using:

rails 3.2.1–ruby1.9.3–os(Windows)

If you use windows xp for ruby on rails then also please download development kit and follow the instruction given below

https://github.com/oneclick/rubyinstaller/wiki/development-kit

http://rubyinstaller.org/downloads/

I’ve used it on both Ubuntu and Redhat Linux successfully.

A friendly advice is to prefer a UNIX based environment - Linux or Mac for both development and deployment because many of the gems available are written in native code and would compile only in UNIX.
This might give you some hints:

http://thefountainofwisdom.blogspot.in/2012/04/deploying-rails-applicaition-on-red-hat.html

If it only compiles on Unix how did you get it to compile on Linux?

Because Linux is a unix-based operating-system. So is a mac.

Since when is Linux based on Unix?

Alright, to be politically correct, Linux is a unix-like operating system.
http://en.wikipedia.org/wiki/Linux

While you're at it read: http://en.wikipedia.org/wiki/Political_correctness
Spoiler: It's not politically correct. It's just correct.

Good to know, thanks!

I think for ror all platform is good if you have a capability to configure

It’s been a while since I used Oracle (and never on Windows), but the instructions here seem to indicate you need to make sure that OCI.DLL is on your PATH:

http://ruby-oci8.rubyforge.org/en/file.install-instant-client.html

You may want to try loading IRB and requiring the library directly, by doing ‘require “oci8”’. If that fails, please post the stack trace + error message.

–Matt Jones

In my win 7 it is working fine