Getting Started

Quoting David James <rails-mailing-list@andreas-s.net>:

Experienced developer here just attacking Ruby on Rails.

So, I bought myself a book (Beginning Ruby on Rails - Holzner) and
proceeded to follow the tutorial for the first project. I start up
Webrick which seems to be working properly. Then, after
editing/creating the two simple files per the instructions I point my
browser at http://localhost:3000/app/greeting. Instead of seeing the
result I was expecting, I got:

=====================
We're sorry, but something went wrong.
We've been notified about this issue and we'll take a look at it
shortly.

Now, I've actually tried a couple of different tutorials with the same
result. When this is displayed in my browser, I also get this webrick
logging (below) in the dos box it is running in, but have no idea what
it means.

Since I've been stuck on this a couple days if anyone can point me to an
approach to getting past this I will greatly appreciate it. Everything
I've done with the tutorial seems to have worked correctly through this
process -- the rails command, the generate controller, starting webrick,
all seem straightforward and like they're working as expected.

TIA

Dave

/!\ FAILSAFE /!\ Fri Mar 20 00:12:27 -0500 2009
  Status: 500 Internal Server Error
  no such file to load -- sqlite3

[snip]

The sqlite3 gem is not installed. This is now the default database adapter.
Rails is a fast moving target and tutorials are quickly out of date. It used
to be MySQL (at least on Linux and I think MacOS). If you have installed a
different database adapter, set the correct value in config\database.yml.
Otherwise, install the sqlite3.

HTH,
  Jeffrey