Error when running ruby script/ generate: please help : error syntax error on line 4, col 15

Hi,

I'm running a ruby script on my mac. I use textmate, mysql query
browser and my sql administrator.

I get an error message when I run ruby script/ generate.

The database energy_development has been set up. But it still gives me
the following error:

creative-models:energy runycalmera$ ruby script/generate scaffold
contract counterparty:sting Close_of_Business:date
contractprice:integer
/opt/local/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 4,
col 15: ` database: energy_development' (ArgumentError)
  from /opt/local/lib/ruby/1.8/yaml.rb:133:in `load'
  from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:
902:in `database_configuration'
  from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:
437:in `initialize_database'
  from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:
141:in `process'
  from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:
113:in `send'
  from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:
113:in `run'
  from /Users/runycalmera/src/energy/config/environment.rb:9
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/commands/
generate.rb:1
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from script/generate:3
creative-models:energy runycalmera$