starting up server

I am working on an existing application and the first time I try and
start up the server I get this message. I have not gotten this
message before when I start the server on other apps. ruby script/
server. There must be things I need to change in the config.
There is a load statement in yaml.rb but not sure of the context as it
relates to argument. Is the error related to the current version of
rails or is it related to the application.

C:/Ruby/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 23,
col 2: ` s
ocket: /tmp/mysql.sock' (ArgumentError)
        from C:/Ruby/lib/ruby/1.8/yaml.rb:133:in `load'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/
initializer.rb:506:i
n `database_configuration'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/
initializer.rb:233:i
n `initialize_database'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/
initializer.rb:94:in
`process'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/
initializer.rb:49:in
`send'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/
initializer.rb:49:in
`run'
        from C:/Ruby/work/rcamaster/config/environment.rb:14
        from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `ge
m_original_require'
         ... 10 levels...
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/
server.rb:3
9
        from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `ge
m_original_require'
        from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `re
quire'
        from script/server:3

I am working on an existing application and the first time I try and
start up the server I get this message. I have not gotten this
message before when I start the server on other apps. ruby script/
server. There must be things I need to change in the config.
There is a load statement in yaml.rb but not sure of the context as it
relates to argument. Is the error related to the current version of
rails or is it related to the application.

sounds like your database.yml file has a syntax error

fred