error: mail requires i18n (~> 0.4.1, runtime)

Hi

Have spent hours trying to set up ruby and rails in order to do a
project for college , have uninstalled /installed etc ...this error
...what does it mean? .... Is their a simple way to rectify this
infuriating mes
sage

I am using windows 7

Thanks in advance

Sarah

I found a previous answer to this question below. I havwe never used
command prompt before :embarrassed:

What do i "select 2"....should i not uninstall the first one as that
seems to be an older version ?

Do this:

Gem uninstall i18n

Select gem to uninstall
1. i18n-0.4.2
2. i18n-0.5.0
3. All versions

select 2

then install rails
gem install rails --force

this should work

Henrik

Does anyone know gow i can uninstall the second gem using command

?

I have tried 18 differnt prompts lol!

When i uses this prompt "Gem uninstall i18n-0.5.0"

it renders this....

"cannot uninstall, check gem list-diln8-0.5.0"

...Anyone?

...Anyone?

What was the problem with the instructions you quoted?

gem uninstall i18n

Select gem to uninstall
1. i18n-0.4.2
2. i18n-0.5.0
3. All versions

select 2

Pressing the '2' button on your keyboard didn't work, or _______?

Alternatively, if you want to remove a specific gem, you can always
use e.g.
   gem uninstall i18n -v 0.5.0

HTH,

Thanks! Hassan for your reply/ help!

I have deleted that version of gem now.