can't activate i18n (~> 0.4.1, runtime) for ["mail-2.2.10"

Hi

Using RoR 3.0.3 on Mac OS X, and am running into the dependency
problems. Please see the error below. I thought bundler was meant to
precisely avoid these problems? thanks a lot for your help

I tried bundle install / check , deleted old lockfile and regenerate
it, but nothing worked.

rails generate controller testcontroller index
/opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:233:in `activate':
can't activate i18n (~> 0.4.1, runtime) for ["mail-2.2.10",
"actionmailer-3.0.3", "rails-3.0.3"], already activated
i18n-0.5.0beta1 for ["activemodel-3.0.3", "actionpack-3.0.3",
"rails-3.0.3"] (Gem::LoadError)
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:249:in
`activate'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:248:in `each'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:248:in
`activate'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:249:in
`activate'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:248:in `each'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:248:in
`activate'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:249:in
`activate'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:248:in `each'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:248:in
`activate'
  from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems.rb:1082:in `gem'
  from /opt/local/bin/rails:18

Thanks a lot

well doing a fresh installation of ruby 1.9.2 , rubygems 1.3.7 (all
from sources) resolved the problem.

aj

I'm having this issue and uninstalling and reinstalling didn't solve
the problem for me. It's some kind of dependency issue because
everything worked before I ran a gem update. I'm just not sure how to
resolve a rails dependency issue.

Please help!

I am a newbie to ruby on rails. Even I faced the same issue as I was
following the book "agile development with rails, 3rd edition." Any
suggestions?

Thanks
vishal