Rails 3 install on Ruby Enterprise

hi there - attempting to sudo gem install rails --pre on a system
running ruby enterprise-1.8.7-2010.02.

however, I'm getting an error: active model requires i18n

before you say anything, I already ran the dependent gems install, too:

gem install tzinfo builder memcache-client rack rack-test rack-mount
erubis mail text-format thor bundler i18n

before that, however, I ran a gem update --system, which updated my
rubygems to 1.3.7 from 1.3.6

to gem install i18n, it says I require rubygems 1.3.6

ugh

is there a way to rollback rubygems to the prior version?
or is there another way to fix this rails 3 install issue I'm having
with i18n?

much thanks!

May be this link will help you.
http://veerasundaravel.wordpress.com/2010/02/15/rails3-beta-installation/

Charlie B99 wrote:

Veera Sundaravel wrote:

May be this link will help you.
http://veerasundaravel.wordpress.com/2010/02/15/rails3-beta-installation/

Still receive error installing rails: active model requires i18n
When I try to sudo gem install i18n, it errors out because it requires
RubyGems 1.3.6 or higher. I have RubyGems 1.3.7 installed. WTF?

Quoting Charlie B99 <lists@ruby-forum.com>:

Veera Sundaravel wrote:
> May be this link will help you.
> http://veerasundaravel.wordpress.com/2010/02/15/rails3-beta-installation/
>

Still receive error installing rails: active model requires i18n
When I try to sudo gem install i18n, it errors out because it requires
RubyGems 1.3.6 or higher. I have RubyGems 1.3.7 installed. WTF?

I received this error too after installing Ruby Enterprise Edition (REE).
RubyGems apparently knows which version or at least path of Ruby it was
installed with and complains in the very unhelpful way you noted about the
conflict. Try changing your PATH shell variable so MRI Ruby is before REE
Ruby.

HTH,
  Jeffrey

Jeffrey L. Taylor wrote:

Quoting Charlie B99 <lists@ruby-forum.com>:

Veera Sundaravel wrote:
> May be this link will help you.
> http://veerasundaravel.wordpress.com/2010/02/15/rails3-beta-installation/
>

Still receive error installing rails: active model requires i18n
When I try to sudo gem install i18n, it errors out because it requires
RubyGems 1.3.6 or higher. I have RubyGems 1.3.7 installed. WTF?

I received this error too after installing Ruby Enterprise Edition
(REE).
RubyGems apparently knows which version or at least path of Ruby it was
installed with and complains in the very unhelpful way you noted about
the
conflict. Try changing your PATH shell variable so MRI Ruby is before
REE
Ruby.

HTH,
  Jeffrey

I got this to work by reinstalling RubyGems via source files in the
original Ruby directory (which is probably the same thing as changing
the PATH, huh?). <shrug> Dunno, but it works now! Thanks!