breaking rails' module naming convention

Hey people,

The module ActiveRecord::ConnectionAdapters::PostgreSQLAdapter lives in the file '..../connection_adapters/postgresql_adapter.rb'. As such it breaks the module naming convention. I would like to do something like that with a plugin. In my init.rb file I would like to say PostgreSQlAdapter which is in a file named postgresql_adapter.rb. How do I do this? Of course I could change the name a bit to fit the convention but I prefer concise elegance. Thanks.

Hey people,

The module ActiveRecord::ConnectionAdapters::PostgreSQLAdapter lives
in the file '..../connection_adapters/postgresql_adapter.rb'. As such it breaks the module naming convention. I would like to do something like that with a plugin. In my init.rb file I would like to say PostgreSQlAdapter which is in a file named postgresql_adapter.rb.
How do I do this? Of course I could change the name a bit to fit the
convention but I prefer concise elegance. Thanks.

You can call things whatever the hell you want and put them where you
want. However if you do that you will need to require the files
explicitly rather than relying on rails finding and loading the file
for you.

Fred

Thanks Fred. I guess I was just wandering whether there was a way to feed the plugin loader a hash mapping or something. In the plugin I'm loading my files first and then doing the relevant module includes. Thanks.

Frederick Cheung wrote: