Plugin naming conventions

Is there a discussion anywhere regarding the naming conventions for plugins? I have just recently forayed into plugin development and, as a neophyte, blindly started naming everything acts_as_ something-or-other. After doing this a few times, I got to thinking that acts_as_* is typically used in model plugins but not so much in controller plugins. I did a bit o' searching but didn't come up with anything helpful, so I thought I'd ask here.

What kinds of questions should I be asking myself about my plugin when trying to decide on a name?

Thanks, Phillip