Where is WillPaginate::Finders ???

Hi All!

It's been a while since I had to ask for help, but I'm back!

I've finished beta testing my big app and started the transition to

production. Everything went fine and the production version was
working till I was asked to add another model (Almost a year
of beta testing and they only come up with it after moving to
production )
I successfully implemented and tested the new code in development
mode, but when I tried to migrate the db, I started getting errors I
have never seen before:
First, using rake db:migrate it complained that I was using version
0.9.2 and the gemfile says 0.8.7 (NOT! The gemfile says nothing
about rake or its versions). I don’t remember doing anything that
should have updated rake.
It recommended performing a to get rake 0.9.2
– I did it, no problem making the upgrade itself.
Unfortunately, after the upgrade, both (rake
is using 0.9.2) and (it says its using rake
0.8.7) produce errors in the form of:
shows: The error is occurring in both production and development modes so
I’m stuck - I can’t do anything new (my next big task was to copy
the old website data into the new website) this might require db
changes (I tried to avoid this, but there is just too much
difference between the sites).
Searching the web shows similar errors with WillPaginate (none with
Finders) dating back to 2007, but nothing that helped me.
I tried editing the Gemfile:
gem “hobo”, “>= 1.3.0.RC2” #RC2 was pre31
but the bundle update still shows 1.3.0.pre31. I have the feeling
that this is not going to solve the WillPaginate problem anyway, but
I had to try.
I need to get the WillPaginate thing fixed so that I can get my
production db to match the code – fortunately the users haven’t
transitioned from the old site yet.
Can anyone help?
Thanks,
Don Z.
P.S. Is there a simple (recipe) way to update to the latest version
of Hobo, since my ill-fated attempt at editing the Gemfile did
nothing? I don’t need to do this except that I don’t want to get
too far behind.

Don Ziesig wrote in post #1018099:

Hi All!

It's been a while since I had to ask for help, but I'm back!

I've finished beta testing my big app and started the transition to
production. Everything went fine and the production version was working
till I was asked to add another model :frowning: (Almost a year of beta
testing and they only come up with it after moving to production :smiley: )

I successfully implemented and tested the new code in development mode,
but when I tried to migrate the db, I started getting errors I have
never seen before:

First, using rake db:migrate it complained that I was using version
0.9.2 and the gemfile says 0.8.7 (NOT! The gemfile says nothing about
rake or its versions).

So let me get this straight, in the past when you've run:

$ bundle install

and you saw the names of 50 gems go streaming by, you never noticed that
most of those gems aren't in your gemfile? Read this:

http://gembundler.com/rationale.html

and this:

http://ryanbigg.com/2011/01/why-you-should-run-bundle-update/

I don't remember doing anything that should have
updated rake.

It recommended performing a /bundle upgrade/ to get rake 0.9.2 -- I did
it, no problem making the upgrade itself.

Unfortunately, after the upgrade, both /rake db:migrate/ (rake is using
0.9.2) and /hobo g migration/ (it says its using rake 0.8.7) produce
errors in the form of:

*uninitialized constant WillPaginate::Finders (NameError)*

/bundle update/ shows: *Using will_paginate (3.0.0) *

The error is occurring in both production and development modes so I'm
stuck - I can't do anything new (my next big task was to copy the old
website data into the new website) this might require db changes (I
tried to avoid this, but there is just too much difference between the
sites).

Searching the web shows similar errors with WillPaginate (none with
Finders) dating back to 2007, but nothing that helped me.

I tried *(this may be totally wrong, it's the hacker in me)* editing the
Gemfile:

gem "hobo", ">= 1.3.0.RC2" #RC2 was pre31

but the bundle update still shows 1.3.0.pre31.

I don't know how ruby determines which version is greater than another
version, but the ascii code for 'p' is higher than the ascii code for
'R', so in that sense 1.3.R is a smaller version number than 1.3.0.p.

Hi All!

It's been a while since I had to ask for help, but I'm back!

I've finished beta testing my big app and started the transition to
production. Everything went fine and the production version was working
till I was asked to add another model :frowning: (Almost a year of beta
testing and they only come up with it after moving to production :smiley: )

I successfully implemented and tested the new code in development mode,
but when I tried to migrate the db, I started getting errors I have
never seen before:

First, using rake db:migrate it complained that I was using version
0.9.2 and the gemfile says 0.8.7 (NOT! The gemfile says nothing about
rake or its versions). I don't remember doing anything that should have
updated rake.

Your Gemfile may not, but your Gemfile.lock will have a specific
version in it.

It recommended performing a /bundle upgrade/ to get rake 0.9.2 -- I did
it, no problem making the upgrade itself.

Unfortunately, after the upgrade, both /rake db:migrate/ (rake is using
0.9.2) and /hobo g migration/ (it says its using rake 0.8.7) produce
errors in the form of:

*uninitialized constant WillPaginate::Finders (NameError)*

/bundle update/ shows: *Using will_paginate (3.0.0) *

hard to tell without a stack trace. At a guess something in your app
was trying to extend that module, which is defunct in will paginate
3.0

The error is occurring in both production and development modes so I'm
stuck - I can't do anything new (my next big task was to copy the old
website data into the new website) this might require db changes (I
tried to avoid this, but there is just too much difference between the
sites).

Searching the web shows similar errors with WillPaginate (none with
Finders) dating back to 2007, but nothing that helped me.

I tried *(this may be totally wrong, it's the hacker in me)* editing the
Gemfile:

gem "hobo", ">= 1.3.0.RC2" #RC2 was pre31

If you know the exact version, i'd try gem 'hobo', '1.3.0.RC2'

Fred