Missing mislav-will_paginate

Try:

gem install will_paginate --remote

Hi, what platform are you on? I’m Mac OS X and you’ll need to do something like this:

sudo gem install mislav-will_paginate --source http://gems.github.com

Good luck,

-Conrad

Here's something you might want to consider.

Create a gem configuration named: ~/.gemrc

Here's the contents of mine (NOTE: the "---" line is part of the
file):

Make sure you have gems.github.com set as a source

# list all current sources (http://gems.rubyforge.org/ is the only one
set by default)
$ gem sources

# if you don't see gems.github.com, add it
$ gem sources -a http://gems.github.com

Then you should be able to install mislav-will_paginate

Just to be clear, your ":version => '~> x.x.x'" clause that you
removed had an actual version number and not x's, right?

Check outhttp://www.rubygems.org/read/chapter/1for details on what's
going on here.

It's working now. Thanks to all who helped. I especially appreciate the
reference. While the help is great - and go me going - knowledge is
going to help me not have to ask dumb questions.

Thanks again
--
Posted viahttp://www.ruby-forum.com/.

Just to be clear, your ":version => '~> x.x.x'" clause that you
removed had an actual version number and not x's, right?

Here's the line from an old app. (It would be a config.gem line for Rails 2.x and include the :source and :lib keys like Billie D. and others have noted.)

# will_paginate: 3.0 will not be backward-compatible, 2.3.2 made a break with the past
# 2.3.6 works, 2.3.11 does NOT due to a change related to an
# ActionView::Base.respond_to?() that incorrectly selects behavior for
# this Rails 1.2.2 app. It probably makes it safe for all 2.x versions.
gem 'mislav-will_paginate', '~>2.1', '>2.3.2', '=2.3.6'

Particularly if you user will_paginate on an older Rails application, you might run into this problem. It is also a good example of how to use version specifications. Initially, only the first two were present with the first comment line to explain. When 2.3.11 broke the app, the version was pinned to the one that was known to work, but the first two specs deserve a bit of explanation:

   ~>2.1 means, roughly, "compatible with 2.1" and is equivalent
           to ">=2.1,<3". This covers the "3.0 will not be
           backward-compatible" part

   >2.3.2 means just what you'd think, past 2.3.2 and covers
           the "2.3.2 made a break with the past" part of the explanation.
           So 2.3.2.w, 2.3.x, 2.4.y or 3.z would do
           fine (where x>2, w,y,z are anything)

-Rob

Rob Biedenharn http://agileconsultingllc.com
Rob@AgileConsultingLLC.com

Yes, that is correct. In my environment.rb file it is listed
as :version => '~> 2.2.3' but I removed that hash key so there is no
reference to a version number.

HTH!

William