URGENT! can't activate actionpack (= 1.13.6, runtime) for ["actionwebservice-1.2.6"], already activated actionpack-2.3.5 for ["rails-2.3.5"] (Gem::LoadError)

Hi guys,

I have added consumption of a couple of web services to my application
and everything seemed to be going well. That is after yesterday, when
I was asked to install whatever I had in a test server that runs in
production mode (used also for demos) and when I tested the production
environment in my PC the mongrel server gave me the above error.

I spent about 3 hours last night googling and seeing how I could fix
the problem but nothing I tried worked. I saw old messages about it
and one of them, from Fred Cheung, I believe, mentioned about freezing
gems. I really would not like to do that unless I have to since I've
never done it before and I don't know the impact that would have in
the rest of the applications we have.

Another post mentioned about getting rid of any actionpack gem higher
than the one required by actionwebservice but I am afraid that doing
so will screw up actionsupport and/or activerecord.

Below is the list of gems currently installed. I would appreciate any
help as I am kind of stuck and need to get this thing done asap.
Thanks in advance

*** LOCAL GEMS ***

actionmailer (2.3.5, 2.2.2)
actionpack (2.3.5, 2.2.2, 1.13.6, 1.13.3)
actionwebservice (1.2.6, 1.2.3)
activerecord (2.3.5, 2.2.2, 1.15.6, 1.15.3)
activerecord-oracle-adapter (1.0.0.9250)
activerecord-oracle_enhanced-adapter (1.2.3)
activerecord-sqlserver-adapter (2.3.5)
activeresource (2.3.5, 2.2.2)
activesupport (2.3.5, 2.3.3, 2.2.2, 1.4.4, 1.4.2)
archive-tar-minitar (0.5.2)
authlogic (2.1.3)
builder (2.1.2)
calendar_date_select (1.15, 1.13)
cgi_multipart_eof_fix (2.5.0)
color (1.4.0)
cucumber (0.6.2)
diff-lcs (1.1.2)
fastthread (1.0.1)
fxri (0.3.6)
fxruby (1.6.6)
gem_plugin (0.2.3)
hoe (1.8.2)
hpricot (0.4)
ibm_db (1.1.1)
json_pure (1.2.0)
linecache (0.43)
log4r (1.0.5)
mongrel (1.1.5)
mongrel_service (0.3.4)
mysql (2.7.3)
paginator (1.1.1)
pdf-writer (1.1.8)
polyglot (0.2.9)
rack (1.0.1)
railroad (0.5.0)
rails (2.3.5, 2.2.2)
rake (0.8.7, 0.8.3)
rspec (1.3.0)
ruby-debug-base (0.10.3, 0.10.2)
ruby-debug-ide (0.4.5, 0.3.1)
rubyforge (1.0.3, 1.0.2, 1.0.1)
rubygems-update (1.3.6, 1.3.5, 1.3.1)
sources (0.0.1)
sqlite3-ruby (1.2.1)
term-ansicolor (1.0.4)
transaction-simple (1.4.0)
treetop (1.4.3)
win32-api (1.4.6)
win32-clipboard (0.4.1)
win32-dir (0.3.1)
win32-eventlog (0.4.3)
win32-file (0.5.3)
win32-file-stat (1.2.3)
win32-process (0.5.1)
win32-sapi (0.1.3)
win32-service (0.7.1, 0.5.2)
win32-sound (0.4.0)
win32console (1.2.0)
windows-api (0.4.0)
windows-pr (1.0.9, 0.6.2)

Another post mentioned about getting rid of any actionpack gem higher
than the one required by actionwebservice but I am afraid that doing
so will screw up actionsupport and/or activerecord.

Below is the list of gems currently installed. I would appreciate any
help as I am kind of stuck and need to get this thing done asap.
Thanks in advance

The core issue is that you have actionwebservice 1.2.6 which requires
active support 1.2.6 but this rest of rails requires active support
2.3.5 (requires in the sense that gem dependencies specify those
versions).

You could look at http://github.com/datanoise/actionwebservice - looks
like it was updated to be inline with 2.3.2 and i'm pretty sure
changes since 2.3.2 that might affect this have been minimal

Fred

Thanks Fred,

I tried to install the last version from datanoise by running "gem
install/update actionwebservice" but that got me nowhere (still
showing actionwebservice 1.2.6). Is that not the install command from
datanoise's gem?

If datanoise's gem is not the same as the 'regular' actionwebservice,
will I need to change my code or is datanoise the "evolution" of the
original actionwebservice?

You mentioned 2.3.2. If I were able to install that gem version, would
I have to work with rails 2.3.2 as well?

Thanks a lot.

Thanks Fred,

I tried to install the last version from datanoise by running "gem
install/update actionwebservice" but that got me nowhere (still
showing actionwebservice 1.2.6). Is that not the install command from
datanoise's gem?

If datanoise's gem is not the same as the 'regular' actionwebservice,
will I need to change my code or is datanoise the "evolution" of the
original actionwebservice?

as i understand it it's just the 'old' actionwebservice updated to
still work with recent versions of rails. You might have to install
the gem by hand (get the source, build the gem with gem build
blah.gemspec and then install the resulting .gem file)

You mentioned 2.3.2. If I were able to install that gem version, would
I have to work with rails 2.3.2 as well?

To run with rails 2.3.5 you would at the very least update the gem to
require that version of actionpack/activesupport etc. There are forks
of that gem that purport to have done that

Fred

as i understand it it's just the 'old' actionwebservice updated to
still work with recent versions of rails. You might have to install
the gem by hand (get the source, build the gem with gem build
blah.gemspec and then install the resulting .gem file)

I'll have to give it a try. Never built a gem from source before,
though. Could be fun. I wish I had more time.

To run with rails 2.3.5 you would at the very least update the gem to
require that version of actionpack/activesupport etc. There are forks
of that gem that purport to have done that

I am guessing that would be just replacing the value of the version
number required? I love Ruby but I'd rather not mess with code that is
not mine or I don't understand. :wink:

Thanks a lot Fred.

> as i understand it it's just the 'old' actionwebservice updated to
> still work with recent versions of rails. You might have to install
> the gem by hand (get the source, build the gem with gem build
> blah.gemspec and then install the resulting .gem file)

I'll have to give it a try. Never built a gem from source before,
though. Could be fun. I wish I had more time.

> To run with rails 2.3.5 you would at the very least update the gem to
> require that version of actionpack/activesupport etc. There are forks
> of that gem that purport to have done that

I am guessing that would be just replacing the value of the version
number required? I love Ruby but I'd rather not mess with code that is
not mine or I don't understand.

At the very minimum. I don't think rails would have changed much in
the sort of ways that would affect this between 2.3.5 and 2.3.2. Some
of the forks seem to have done that change already.

Fred

Thanks again Fred.