Trouble starting WEBrick server

Hello every body, I just started working on Ruby on Rails and as i am
progressing I noticed that I can not start my WEBrick server on the
Command prompt. The following are the various error messages that I am
going.

Microsoft Windows [Version 6.0.6002]

C:\Users\imedia2\Desktop\test\helloworld>ruby script/server
=> Booting WEBrick
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2010-03-24 22:07:52] INFO WEBrick 1.3.1
[2010-03-24 22:07:52] INFO ruby 1.8.6 (2008-08-11) [i386-mswin32]
[2010-03-24 22:07:52] WARN TCPServer Error: Only one usage of each
socket address (protocol/network address/port) is normally permitted.
- bind(2)
Exiting
C:/Ruby/lib/ruby/1.8/webrick/utils.rb:73:in `initialize': Only one
usage of each socket address (protocol/network address/port) is
normally permitted. - bind(2)
(Errno::EADDRINUSE)
        from C:/Ruby/lib/ruby/1.8/webrick/utils.rb:73:in `new'
        from C:/Ruby/lib/ruby/1.8/webrick/utils.rb:73:in
`create_listeners'
        from C:/Ruby/lib/ruby/1.8/webrick/utils.rb:70:in `each'
        from C:/Ruby/lib/ruby/1.8/webrick/utils.rb:70:in
`create_listeners'
        from C:/Ruby/lib/ruby/1.8/webrick/server.rb:75:in `listen'
        from C:/Ruby/lib/ruby/1.8/webrick/server.rb:63:in `initialize'
        from C:/Ruby/lib/ruby/1.8/webrick/httpserver.rb:24:in
`initialize'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/
handler/webrick.rb:10:in `new'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/
handler/webrick.rb:10:in `run'
        from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/
server.rb:111
        from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
        from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from script/server:3

Please i will be very happy if i receive a reply. thank you all.

It means you already have something, probably another instance of
webrick, listening on that port. Find it and shut it down before trying
to start a new instance.

Hi Hassan,

There was a sudden power outage and therefore Webrick couldn't be
shutdown gracefully. On machine restart, I got the exact same error as
Gordons, however, my Ruby is 1.8.7 and I'm on a WinXP machine.
Additionally, I found that none of my browsers (IE/Firefox) can connect
to any website.

I would be thankful if you can explain step-by-step how to find out
whether another instance of Webrick is running and how to shut it down.
Of course, I tried browsing to 127.0.0.1:3000, but my browsers have been
affected, so the page cannot be displayed.

Thanks in advance.

CTRL+SHIFT+ESC and search for webrick or ruby, right click, murder/kill

Thanks, Jordon. I already tried that, there's no Webrick or Ruby process listed.

Jordon Bedwell <envygeeks@...> writes:

?! It's been years since I've touched a Windows machine, but that
sounds like your system is totally b0rk3d. Do you have a firewall
of some sort that might be affecting networking?

Try using basic networking tools like ping, traceroute, telnet, etc.;
if your system crash was extremely ungraceful, you might have an
OS reinstall ahead of you...

Good luck,

So your system is basically broken. Seriously, I think it's time for an
OS reinstall - preferably with some version of Linux :slight_smile:

Unless you can find someone who knows Windows who can help
you troubleshoot this, but that's not me; sorry!

Best of luck, though.

Tried a different port ?
eg: rails s -p 9001

I had a hunch that reinstallation or trying a different port weren’t necessary. I probed a bit more and found some processes named netsession_win.exe in Task Manager. I stopped these. I then went on to uninstall some software named Akamai* from Add/Remove programs, and now all is well.

Hope this helps someone else.

change port number and start server