The Rails server(WEbrick) does not start

Hi Guys:
I'm new to Rails , I just installed it today, and tried to deploy an app
on the localhost, when i run the rails server
i got it like the screen-shot, there's no error message, WEbrick does
not start , it automatically "quits", tried many times, what probable
causes could there be , and how to solve it?
Many Thanks.
Rails version 3.2.1
Ruby 1.9.3

Attachments:
http://www.ruby-forum.com/attachment/7100/prob_rails.jpg

Looking at the screenshot it seems you created an application in a
path with spaces (Documents and Settings)

Please avoid spaces in the path. Please create another application in
a directory without spaces.

If you installed RailsInstaller, you can create your application
inside C:\Sites directory.

Hope that helps.

Yes, and stop programming rails under Windows =)
https://www.virtualbox.org/ with Linux is the best choice.

Thank you for your reply, the 'space' isn't the cause of it, run on the
root folder of the disk, same.check the new screen-shot.

Attachments:
http://www.ruby-forum.com/attachment/7104/prob_rails2.jpg

What is the result of:

ruby script\rails server

Also, do you have any Firewall or something that could be blocking?

We need more information about your environment:

gem env

For some reason webrick is not starting properly, so there must be
something in your setup that is producing that.

Can you start a console instead?

ruby script\rails console