Support for sub-second support for SQLite adapter

Hey All,

I've created a patch to add sub-secord support for SQLite.
Incidentally, it's basically a clone of the Postgres sub-second patch
I made a couple of years ago.

Can someone please take a look at the patch and then slide it in to
the next Rails release? I can bribe you with chocolate if required.

Ticket #1982 - https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/1982

Thanks,

Alex.