Starting Mongrel failes on Mac OS 10.6

after spending some hours on installing ruby on rails, I passed the
point to start my server.

"hours"? That doesn't sound promising :slight_smile:

But mongrel failed to start with the following message:

/usr/local/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/
mongrel.rb:10:in `initialize': wrong number of arguments (5 for 4)
(ArgumentError)

1) What command are you using to start it?
2) Does webrick start?
3) What does `gem list --local` produce?

Sorry for that, but first I gone the wrong way and after some hours I
noticed how easy it is to install rails.. I use the command "ruby
script/server". How do I see if webrick starts?

prompt% script/server webrick

Output of "gem list --local":

actionmailer (2.3.8)
actionpack (2.3.8)
activerecord (2.3.8, 2.3.4)
activeresource (2.3.8)
activesupport (2.3.8, 2.3.4, 2.2.3)

Whatever "wrong way" you started out with, you might want to just
`sudo gem uninstall rails` completely, and then re-install it.

Did you create your test project before or after you installed the 2.3.8
version of Rails?

Gregor <gregor.mitzka@...> writes:

> > Sorry for that, but first I gone the wrong way and after some hours I
> > noticed how easy it is to install rails.. I use the command "ruby
> > script/server". How do I see if webrick starts?
>
> prompt% script/server webrick
>
> > Output of "gem list --local":
>
> > actionmailer (2.3.8)
> > actionpack (2.3.8)
> > activerecord (2.3.8, 2.3.4)
> > activeresource (2.3.8)
> > activesupport (2.3.8, 2.3.4, 2.2.3)
>
> Whatever "wrong way" you started out with, you might want to just
> `sudo gem uninstall rails` completely, and then re-install it.
>
> Did you create your test project before or after you installed the 2.3.8
> version of Rails?
>
> --
> Hassan Schroeder ------------------------ hassan.schroe...@...
> twitter: @hassan

Yeah, I re-installed rails and it doesn't work at all. The project was
created after installing version 2.3.8 and it's a riddle to me, why
there are different versions of some packages.

I am having the same problem on on Ubuntu. Did you find a solution?

script/server

fails with

=> Booting Mongrel
=> Rails 2.3.8 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/mongrel.rb:10:in
`initialize': wrong number of arguments (5 for 4) (ArgumentError)

While script/server webrick works fine.

cheers,
Morten

Morten Lindow <morten.lindow@...> writes:

I am having the same problem on on Ubuntu. Did you find a solution?

I had the same issue recently and all Google turned up were numerous
different web sites mirroring this same thread. Thus, for the sake of
archives, here's what fixed it for me, even if it might be too late for
the original poster.

This is another one of those "an API change broke other software so you
have a cascade of enforced upgrades" issues. Mongrel and Rack fell out
this time. Rack 1.1.0 (for recent releases of the Rails 2.3.x series)
seems incompatible with comparatively old Mongrel releases. Mongrel's in
a gem too and was at version 1.0.1 on my machine. Updating it to the
time-of-writing latest version 1.1.5 fixed the problem, though it pulled
in a few other gem updates in passing.