Server issues

Hello out there,

I'm just twiddling with 1.2-R2 but I have some Problems with the Server configurations. I tried lighttpd and it works now, but I ran into the problem of too long pathnames that caused lighttpd to exit unintentionally. I moved my project folder to my home-root and now it works. But lighttpd is not so fine for development because the fcgi processes are keeping my classes in memory.
When I try mongrel I get on any request this

Error calling Dispatcher.dispatch #<ArgumentError: wrong number of arguments (0 for 1)>

-error, which walks right through Rails - am I allowed to post complete traces of these errors here in this Mailing-List and has somebody experienced the same problem?
After the first request it takes one minute to kill mongrel, maybe it lost a thread for something I would like to know.

Last - bnl - there is something called webrick, which is, I though, a pretty robust slave in this kind of situations.

It just gives me:

#<ArgumentError: wrong number of arguments (0 for 1)>

and my browser only displays:

Not Found
`/' not found.
WEBrick/1.3.1 (Ruby/1.8.5/2006-08-25) at localhost:3000

Webricks trace is not clear at all... :frowning:

I'm using OSX-4, Intel, Self-Compiled Ruby 1.8.5 with gem 0.9.

I still can't get any of mongrel or webrick to work in development mode, production works fine.

Attached: webrick trace

webrick.txt (2.36 KB)

Ok, I also tested with Rails 1.1.6, Ruby 1.85.

I put my freezed to 1.1.6 rails application in /tmp for a short path and started webrick in both production und development and as normal or superuser.

Environment production worked like a charm but in development rails always tells me that the dispatcher raises an argument error, with wrong number of arguments. This happens with mongrel and webrick wherefor mongrel needs 60 seconds to shutdown because it lost a thread and webrick didn't even find a controller and displays '/' not found.

Thanks for any help
Florian