Argument Error w/ require_or_load in Edge

My application fails under latest Edge (Full Error Trace below) giving me a generic Argument Error (wrong number of arguments (2 for 1)) each time i hit any page in Development mode. The app starts up fine (Mongrel) initially. When Using Webrick i dont get any errors at all, just a blank page, so the problem is not related to Mongrel specifically.

I had not done an svn up since early August, so the problem must relate to changes introduced this month. Also, reverting rails to 1.1.6 works without any problems. Looking at dispatcher.rb i honestly cannot make any sense of it. I do not use any engines (although the engine plugin itself is installed and updated to 1.1.4) and i also tried throwing out all my modular routes to no effect. Any help would be appreciated.

Full Error Trace:
vendor/rails/railties/lib/dispatcher.rb:104:in `require_or_load'
vendor/rails/railties/lib/dispatcher.rb:104:in `prepare_application'
vendor/rails/railties/lib/dispatcher.rb:39:in `dispatch'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel/rails.rb:82:in `process'
/usr/local/lib/ruby/1.8/sync.rb:229:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel/rails.rb:81:in `process'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel.rb:577:in `process_client'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel.rb:576:in `process_client'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel.rb:683:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel.rb:683:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel.rb:670:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel/configurator.rb:267:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel/configurator.rb:266:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/mongrel_rails:127:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel/command.rb:203:in `run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/mongrel_rails:231
vendor/rails/activesupport/lib/active_support/dependencies.rb:343:in `load'
vendor/rails/railties/lib/commands/servers/mongrel.rb:48
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
vendor/rails/activesupport/lib/active_support/dependencies.rb:350:in `require'
vendor/rails/railties/lib/commands/server.rb:39
script/server:3