rvm and phusion passenger

I have two rails applications currently running on systemruby which is
version 1.8.6. And I am using phusion passenger with apache to run the
applications. My new requirement is to run one of the applications in
Ruby1.8.7. For that I have set up 1.8.7 with RVM. But I dont know how to
modify my existing /etc/httpd/conf/httpd.conf to run one application in
Ruby1.8.6 (Sytem ruby) and second one in ruby1.8.7 (from RVM). Please
help me

Thanks
Tom

It is not possible.

I think that you must use passenger + passenger lite

Robert Pankowecki
http://robert.pankowecki.pl

Hi Tom,

If you are or can run passenger 3.x, then you can use passenger-
standalone proxy'd via apache to handle multiple / different ruby/
rails combinations. Check out

http://blog.phusion.nl/2010/09/21/phusion-passenger-running-multiple-ruby-versions/

"One of the questions we’ve been getting a lot lately is whether it’s
possible to run multiple Ruby versions with Phusion Passenger, .... As
of Phusion Passenger 3 you can run all components as Phusion
Passenger.

...

... Passenger Standalone was designed to be able to used in a reverse
proxy environment such as the one demonstrated in this article. Unlike
Mongrel and Thin clusters however you only need a single Phusion
Passenger Standalone instance per web application and thus only a
single address to proxy to. ..."

Jeff

Hi
   Thanks for the reply. I followed
http://blog.phusion.nl/2010/09/21/phusion-passenger-running-multiple-ruby-versions/

I started with
passenger start -a 127.0.0.1 -p 3000 -d

And I am getting an error. Complete trace is attached. Please have a
look

Thanks

Attachments:
http://www.ruby-forum.com/attachment/5672/error.txt