Any pioneers who've configured passenger to support some apps running in 1.8.x others in 1.9?

Passenger configuration selects which ruby executable to use via a global configuration variable (at least for Apache, I assume it's the same for Nginx).

I'm in a situation where I've got at least one rails app I'd like to run on 1.9 while others remain on 1.8. This is for my development machine running OS X 10.6. Normally I just use the Passenger PrefPane, which makes a very comfy setup.

With the current state of Passenger, I think doing this would involve generating a separate 1.9 version of the Passenger Apache module and some how installing both, a probably forgoing the PrefPane for at least one of the ruby versions.

Has anyone trod this road before? Is there an easier way. Am I crazy?

Those questions are not meant to be mutually exclusive.