passenger for both rails 2.3 and 3.0

Hi,

I installed ruby 1.8.7 and passenger 3.0 for apache2 on Ubuntu 10.10.
Rails 2.3 works fine.
But Rails 3.0 gives an error saying that rack version is not 1.2.1.
If I upgrade the rack to 1.2.1, then rails 2.3 app complains that the
rack version is not ~>1.1.0.

How do I satisfy both rails 2.3 and 3.0?
Passenger standalone seems to be an option but I want to know if there's
a better way.

Thanks.

Sam

hmmm... So you're using Rails 2.3 and 3.0 versions?

Luis Saffie

Sam Kong wrote in post #957571:

Hi,

I installed ruby 1.8.7 and passenger 3.0 for apache2 on Ubuntu 10.10.
Rails 2.3 works fine.
But Rails 3.0 gives an error saying that rack version is not 1.2.1.
If I upgrade the rack to 1.2.1, then rails 2.3 app complains that the
rack version is not ~>1.1.0.

How do I satisfy both rails 2.3 and 3.0?
Passenger standalone seems to be an option but I want to know if there's
a better way.

As long as you're using the same Ruby for both 2.3 and 3.0, you
shouldn't need Passenger standalone, if I understand correctly. Just
use regular Passenger and RVM.

Thanks.

Sam

Best,