"Running rake doc:guides will put a full copy of the Rails Guides in the doc/guides "

dear co-grouppers,

The subject line quotes the famous Ruby on Rails Getting-Started Guide
(section 13 What’s Next?)
but my terminal responded with:
"rake aborted!
no such file to load -- redcloth".

What's up? Why did it happen to me? How to get through and live on?

yours`
sehrguey

You need to install the RedCloth gem. http://redcloth.org/

sudo gem install redcloth

Sorry, it should be sudo gem install RedCloth

dear Rafael,

thank you for your help.

I install RedCloth 4.2.9. with a bunch of its gemDocs and other things and once again typed ’

rake doc:guides

’ into commandline just to see again that rake is aborted!

When I ran the command with option ‘–trace’ the terminal revealed requirement for ‘redcloth’ gem but that was not found in any repository.

What now, querido amigo?

yours`

sehrguey

you have to specify the dependency in the application’s Gemfile file then (just installing it doesn’t require it), it should be something like this:

gem ‘rails’

gem ‘RedCloth’

after that do a ‘bundle install’, then run rake doc:guides again. it should work this time, if it doesn’t then do this:

gem ‘RedCloth’, :require => ‘redcloth’

See ya.

Rafael,

all worked as you predicted.

Thanks a lot.

You’re da man.

yours`

sehrguey