Ruby Gems version issue

Hi,

When I try to launch my ruby on rails server, it says my ruby gems
version is not up to date. However it is. I've even tried reinstalling
ruby gems to the latest version, but it still says I have an old
version. Does anyone know how to fix this issue? I'd be deeply
grateful.

Here is some code directly from my terminal (I'm on an ubuntu system):

connor@connor-desktop:~/Desktop/project$ sudo ruby script/server
[sudo] password for connor:
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update
--system` and try again.
connor@connor-desktop:~/Desktop/project$ gem update --system
Updating RubyGems
Nothing to update

Any ideas?

Rubygems 1.2 had issues self updating. There are more instructions at
http://rubyforge.org/forum/forum.php?forum_id=28071

Fred

Doesn't ubuntu restrict the use of gems updating the system? Sudo gem
update --system doesn't work on ubuntu (at least not on version since
hardy). Canonical maintains the packages so you have to get every
thing from apt-get.

Try to update gems via the synaptic package manager. Might be the way
to go.

Connor,
yesterday,i have encounter same problem,but i resovled.so two comand can save your annoy.

sudo gem install rubygems-update

sudo update_rubygems

– tommy xiao