Can't start script/server

Hi,
I get the error saying that my rubygems are of a version to old for
rails... But its not the truth (see the output below please).

$ ruby -v
ruby 1.8.7 (2008-05-31 patchlevel 0) [i686-linux]

$ rails -v
Rails 2.1.0

$ gem -v
1.1.1

#below is in an app directory, after successfully executing `rails app`

$ ruby script/server
Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again:
http://rubygems.rubyforge.org

Did anyone face the same problem?
System is Ubuntu 8.04 i386

I followed this manual
http://wiki.rubyonrails.org/rails/pages/RailsOnUbuntu
and everything seems to work now. Seems like I've been missing one of
the packages or something, cuz otherwise I've been doing the same
thing...

Victor Bobrov wrote:

Probably just needed to udpate rubygems, which was part of that
tutorial it seems :).

sudo gem update --system

-John

John wrote:

sudo gem update --system

$ gem -v
1.1.1

Rails requires RubyGems >= 0.9.4.

gem sez it's the right version. Is there some hidden thing to update behind that??