erro: [Rails requires RubyGems >= 0.9.]

Hello everyone,

System is Ubuntu 8.04 i386

I hava install ruby,rails,etc.

$ ruby -v
ruby 1.8.7 (2008-05-31 patchlevel 0) [i686-linux]

$ rails -v
Rails 2.1.0

$ gem -v
1.1.1

#below is in an app directory, after successfully executing `rails app`

$ ruby script/server
Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again:
http://rubygems.rubyforge.org

Did anyone face the same problem? and can provide a solution?thanks a
lot?
I hava googled and googled,unfortunately, cann't find answer.

That means that when rails did require 'rubygems' nothing good happen.
What happens if you stick
require 'rubygems'
into an irb session ?

Fred

Just resolved that issue...Download the new RubyGems, untar and run
sudo ruby setup.rb (from the rubygems folder you just created)
you may have to reinstall the rails gem as well
sudo gem install -v=2.1.0 rails