Odd script/server error

hi,

I am fairly new to rails, I started learning it about 6 months ago,
but stopped when a big project came up. That was on a Windows machine.
Since then, I have purchased a mac power book. I am ready to again. I
installed rails following the much used HiveLogic tute and everything
seemed to work.

In any event I created a small test app: controller, view, etc in a
directory in ~/Documents/rails/app/demo.

When I created the app, I made a simple controller and view and
started teh server (script/server) and everything worked fine. I
restarted my computer and went to start the server (I am in the
'demo') directory I get this error:

Rails requires RubyGems >= 0.9.4. Please install RubyGems and try
again: http://rubygems.rubyforge.org

This doesn't seem to make sense because when I update something using
he gems command it works, furthermore, when I test the gems version I
get this:

$ gem --version1.0.1

I am running Rails 2.02

and Ruby: 1.8.2 (2004-12-25) [universal-darwin8.0]

on OS X 10.4

Any ideas?

To get the gem version do:

gem env

  1. sudo gem update --system.
    This will upgrade the Ruby gems to 1.0.1

  2. sudo gem install rails --source http://gems.rubyonrails.org

    Note that gem install -y is the default, so you don’t have to provide it.

Thanks for the reply, but that is not the issue, I already have the
most recent version of both gems and rails, I feel as though the error
is wrong, and that the issue it is giving is not correct. that is to
say, I have done something wrong, but not having gems installed is not
the issue.

Thanks for the reply, but that is not the issue, I already have the
most recent version of both gems and rails, I feel as though the error
is wrong, and that the issue it is giving is not correct. that is to
say, I have done something wrong, but not having gems installed is not
the issue.

This doesn't seem to make sense because when I update something
using
he gems command it works, furthermore, when I test the gems
version I
get this:

$ gem --version1.0.1

I am running Rails 2.02

and Ruby: 1.8.2 (2004-12-25) [universal-darwin8.0]

on OS X 10.4

That's the antique version of ruby that Tiger shipped with isn't it?
If you followed the hivelogic tutorial you;ll have a new version
installed, is your $PATH currently set properly so that the new
version of ruby (which will have a separate set of gems etc..) is
invoked ?

Fred

Hi,

I get the same error on my ubuntu linux installation when I create a
new rails-project.

tn@spike:$ ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-linux]
tn@spike:$ gem -v
1.0.1
tn@spike:$ ruby script/console
Rails requires RubyGems >= 0.9.4 (you have 0.9.0). Please `gem update
--system` and try again.

It works fine for old projects though? The gem version control seems a
bit buggy. Any ideas what to do? I've tried to reinstall rubygems, but
it don't help.

Best regards,
Tobias