RubyGems update

I have RubGems 1.1.0 installed on my Fedora Core 5 machine along with a
lot of rails 2.0.2 stuff. I want to upgrade to version 1.2.0 as easily
as possible. I typed in:

gem update --system

as root but that did not do it. It says nothing to update.

How do I upgrade it?

Thanks.

Bharat

you can use:

gem update rails

or

gem install rails

to get the latest version. the “update --system” will update the rubygems software

AnnaLissa, thats exactly what Bharat wants :stuck_out_tongue: To update RubyGems (not rails)

I get a similar problem on a Mac. It worked once, but I had to roll back to 1.1.x because it wouldn’t find Piston. Now it wont update to 1.2.0 at all. Keeps reporting “Nothing to update”.

Regards
Kieran

Sorry about that. Obviously not thinking too straight on this holiday. :slight_smile:

after a quick search, I found this:
http://rubyforge.org/tracker/index.php?func=detail&aid=20775&group_id=126&atid=575

As suggested, perhaps running this command first might do the trick:

gem install rubygems-update -v 1.1.1

Regards,
a.l.

Here is what worked for me last night:

gem install rubygems-update
update_rubygems

Note that on systems like Ubuntu, you have to precede these commands
with "sudo", I was updating a Fedora box.

I got these instructions from the following link:

http://www.rubygems.org/read/chapter/3

If you scroll down to section 3.3 titled Updating RubyGems, you will see
them.

Note that these instructions are listed for updating RubyGems prior to
0.8.5, however, they worked for me even though I was upgrading from
RubyGems 1.1.0. I am not arguing with what works.

Hope this helps.

Bharat