ruby gems error?

I suspect either you don't have 1.1.6 installed,

verify by running "gem query list" from cmd line.

Or, you application is pegged to 1.2. Did you "rails my_app" with 1.2 installed? You may want to delete and redo that command with 1.1.6.

Also, you can check which rails version your app is pegged to by looking in environment.rb

You will see something like...

# Specifies gem version of Rails to use when vendor/rails is not present

if it says 1.2.1, that's at least part of your problem.


dan schrieb:

Well, that's sounds frustrating.

first, "rails my_app" was a bit vague, properly stated I meant the standard "rails /path/to/my_app" command which generates the skeleton Rails application.

I would caution against jumping straight to 1.2.1, if there are plugin dependencies in the app you could be headed for more heavy weather.

Have you tried a "gem install rails -v 1.1.6". You'll need to specify 1.1.6, otherwise you default to 1.2.

Try "gem install --help" for more details.

I would "rails /path/to/my_app" in a new folder to create a clean skeleton app with all necessary components. Then I would copy in (copy over as necessary) the client provided application.

Good luck,


dan schrieb:

yes, you have both rails on your machine.

gem -v is telling you the version of the RubyGems package manager. Thus 0.9.0 is correct.

going back to the original error post, look at environment.rb line 59. My guess is that you'll see some sort of Plugin include statement. If it's not installed in the vendor/plugins folder, well that would be a problem.

then you'll need to do (from app root) "ruby script/plugin install required_plugin_name_here"


dan schrieb: