Install older version of rails FAILED

Help! I need your help!!!

I have an old rail app which I made a few years ago. Never touched rails since.

Now, I need to make it work again. I used the above command to install rails, but I still get rails 2.1.1

[b]gem install rails --version 1.2.6[/b]

I tried twice, and fails twice, even the installation says

Successfully installed activesupport-1.4.4 Successfully installed activerecord-1.15.6 Successfully installed actionpack-1.13.6 Successfully installed actionmailer-1.3.6 Successfully installed actionwebservice-1.2.6 Successfully installed rails-1.2.6 6 gems installed Installing ri documentation for activesupport-1.4.4... Installing ri documentation for activerecord-1.15.6... Installing ri documentation for actionpack-1.13.6... Installing ri documentation for actionmailer-1.3.6... Installing ri documentation for actionwebservice-1.2.6... Installing RDoc documentation for activesupport-1.4.4... Installing RDoc documentation for activerecord-1.15.6... Installing RDoc documentation for actionpack-1.13.6... Installing RDoc documentation for actionmailer-1.3.6... Installing RDoc documentation for actionwebservice-1.2.6...

Any help would be really appreciated...

Now, the version seems correct, but I cannot start the webrick server. The error message is exact the same as before...

The application I did not change a single bit since 2006.

The problem you've got here is probably that the version of rubygems
you've got is too new for the version of rails you've got. Replacing calls to require_gem with calls to gem should do the trick. Fred