Ruby 1.9 compat: ActiveResource::Connection#http.use_ssl (lh #1272, #1872)

Hey guys,

could someone please apply the patch below from #1272 [1]? Doing so
would also close the #1872 [2].

Thanks,
Niels

[1] https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/1272-ruby19-incompatibility-activeresourceconnectionhttp-use_ssl
[2] https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/1872-use-of-undocumented-nethttp-method-breaks-23-on-ruby-191

From dad610b5ae3e73a42b0455bdcb4736b9bbd3f140 Mon Sep 17 00:00:00 2001