rmagick on windows

This book covers it.

/sorry, shameless self-promotion.

http://www.oreilly.com/catalog/railsonwindows/

It’s not that hard, but it has to be done in the right order.

Whoops…

Install imagemagick first, make sure you install the one that comes with the windows gem.

You downloaded this one?

http://rubyforge.org/frs/download.php/15132/RMagick-1.14.1_IM-6.3.0-7-Q8.zip

I've been battling with imagemagick and rmagick all day, initially
getting the same missing CORE_.. .dll error message. I finally got
them both installed, these versions:

rmagick-1.14.1-win32.gem
ImageMagick-6.3.5-5-Q16-windows-dll.exe

And now I'm getting this error:

This version of RMagick was created to run with ImageMagick 6.3.0
but ImageMagick 6.3.5 is installed on this system. You should either
   1) Configure and build RMagick for ImageMagick 6.3.5, or
   2) download ImageMagick 6.3.0 from http://www.imagemagick.org and
install it.

I don't think I'm up to the task of option 1, and I can't find a 6.3.0
imagemagick windows binary anywhere (including the imagemagick
mirrors)? Does anyone have a 6.3.0 imagemagick windows binary?

Thanks.

Hey,

How did you get that gem? Did you get it standalone or did you get that
in a zip file?

If my memory serves me right I downloaded a zip file which had both the
gem and the imagemagick installer. You install imagemagick (using the
exe in that zip file) first and then use the gem in that zip file to
install rmagick.

HTH.

Deepak

macanudo wrote:

In fact, I think used the zip file from this link :
http://rubyforge.org/frs/download.php/15132/RMagick-1.14.1_IM-6.3.0-7-Q8.zip

Let us know how that goes.

Deepak

N. C. Deepak Ramesh wrote:

Thanks Deepak. I do have the version of rmagick you linked to, I just
overlooked that it also included the compatible version of
imagemagick. I installed the compatible version and that problem is
gone now.

The problem I'm now having is that when I run this:

rake test:plugins PLUGIN=acts_as_attachment \

(using acts_as_attachment is my ultimate goal here), I am getting
errors related to sqllite (which I don't use and have no interest in
using)! So now I'm trying to install sqlite dlls and gem to get past
these errors. The current error is this:

The procedure entry point sqlite_libencoding could not be located in
the dynamic link library sqlite.dll

Does this error matter if I'm not using sqlite? I guess I'd just like
to see the acts_as_attachment plugin test succeed, maybe it doesn't
need to?

I deleted the references to sqlite in the a_a_a database.yml file, and
got past the error!

Now the a_a_a plugin test completes (yes!), but doesn't exactly pass
with flying colors:

80 tests, 238 assertions, 23 failures, 6 errors

Not sure what to do next, any advice appreciated.

Ignore those errors. They are related to SQLite. They use SQLite because it’s a compact, portable database that works everywhere and can be used for in-memory db operations in unit tests. It’s a breeze to install in windows (just go to sqlite.org and grab the windows dll and place it in c:\ruby\bin, then gem install sqlite3-ruby)

After a lot of frustration, and dollowing several dead-ends, I finally
found this thread and it solved the buffer overflow.

Thanks!

Did you add require 'RMagick' to environment.rb or to the
model or controller that uses it?

Aya Aya wrote:

I believe it's RMagick, not rmagick.

Aya Aya wrote:

Yup… The book assumes that you’re not using InstantRails at that point. RMagick and all other gems are installed more easily if you install Ruby and Rails manually. The reason for this is that because InstantRails is self-contained and not on your path, you have to do all of your work from within the Instantrails directory.

Sorry for the confusion.

Thank you guys. This was helpful.

A whole day of effort - I wish I had found this earlier

~r
http://www.pilotoutlook.com