rake aborted! undefined method `autoload!'

Hi!

I made a app in rails 3.0.0, but when i try to upload to my hosting i
take to change the version of rails to rails 3.0.0.beta4

Im make the bundle install and every step cool, but when i try to do the
rake db:migrate i have the next error...

-bash-3.2$ rake db:migrate --trace
(in /home/aerotour/public_html/aeto)
rake aborted!
undefined method `autoload!' for #<Rails::Paths::Path:0x30a79160e50>
/home/aerotour/.bundle/ruby/1.8/gems/railties-3.0.0.beta4/lib/rails/
paths.rb:16:in `method_missing'
/home/aerotour/.bundle/ruby/1.8/bundler/gems/devise-
d498cf3a4e1a3fef3f4f071d4feec6a489efe480-master/lib/devise/rails.rb:10
/home/aerotour/.bundle/ruby/1.8/gems/activesupport-3.0.0.beta4/lib/
active_support/dependencies.rb:212:in `require'
/home/aerotour/.bundle/ruby/1.8/gems/activesupport-3.0.0.beta4/lib/
active_support/dependencies.rb:212:in `require'
/home/aerotour/.bundle/ruby/1.8/gems/activesupport-3.0.0.beta4/lib/
active_support/dependencies.rb:198:in `load_dependency'
/home/aerotour/.bundle/ruby/1.8/gems/activesupport-3.0.0.beta4/lib/
active_support/dependencies.rb:554:in `new_constants_in'
/home/aerotour/.bundle/ruby/1.8/gems/activesupport-3.0.0.beta4/lib/
active_support/dependencies.rb:198:in `load_dependency'
/home/aerotour/.bundle/ruby/1.8/gems/activesupport-3.0.0.beta4/lib/
active_support/dependencies.rb:212:in `require'
/home/aerotour/.bundle/ruby/1.8/bundler/gems/devise-
d498cf3a4e1a3fef3f4f071d4feec6a489efe480-master/lib/devise.rb:358
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:
46:in `require'
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:
46:in `require'
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:
41:in `each'
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:
41:in `require'
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:
40:in `each'
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler/runtime.rb:
40:in `require'
/usr/lib/ruby/gems/1.8/gems/bundler-0.9.26/lib/bundler.rb:89:in
`require'
/home/aerotour/public_html/aeto/config/application.rb:7
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/home/aerotour/public_html/aeto/Rakefile:4
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `load'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in
`raw_load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2017:in
`load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2016:in
`load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2000:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

Im working in Site5.

I hope you can orient me how i can fix this.

Thank you for you time!